Impossible to publish or update job offers
Incident Report for Welcome to the Jungle
Resolved
Everything is back on track! 🙌
Posted Mar 17, 2021 - 14:33 CET
Investigating
We are currently investing an issue reported on our products Welcome Kit and Welcome to the Jungle.
Several users are having issues to publish or update job offers or access several pages.
We will publish update as soon as possible.

We are deeply sorry for the inconvenience.
Posted Mar 17, 2021 - 11:19 CET
This incident affected: Welcome to the Jungle main website, Welcome to the Jungle Solutions ATS, and Welcome to the Jungle Solutions ATS - Careers Websites.