Language versions are not all available
Incident Report for Welcome to the Jungle
Resolved
The issue is now resolved.
Posted Oct 22, 2021 - 09:34 CEST
Identified
We have identified the issue and working on a fix that should be available for everybody tomorrow morning.
Posted Oct 21, 2021 - 17:30 CEST
Investigating
Our company pages dont show their traductions when they should.
More information will come shortly.
Posted Oct 21, 2021 - 15:28 CEST
This incident affected: Welcome to the Jungle main website.