Apply errors on some WelcomeKit careers websites
Incident Report for Welcome to the Jungle
Resolved
The incident has been resolved.
Posted Oct 28, 2022 - 14:44 CEST
Identified
Some of our users experience an error when they try to apply on some of careers websites.
Posted Oct 28, 2022 - 13:50 CEST
This incident affected: Welcome to the Jungle Solutions ATS - Careers Websites.