Part of Welcome to the Jungle Candidates platform is unaccessible.
Incident Report for Welcome to the Jungle
Resolved
Welcome to the Jungle is back on track! 🙌
Posted Nov 26, 2020 - 15:35 CET
Identified
The issue is being fixed and is due to recent improvements.
Only candidates who recently submitted a spontaneous application are affected.
We are sorry for the inconvenience.

More informations shortly on this page.
Posted Nov 26, 2020 - 11:00 CET
This incident affected: Welcome to the Jungle main website.