Latency on WelcomeKit
Incident Report for Welcome to the Jungle
Resolved
This incident has been resolved and everything is now fine.
Posted Jul 20, 2021 - 14:10 CEST
Investigating
The user experience is degraded on Welcome Kit due to server latency. We are investigating the issue.
Posted Jul 20, 2021 - 11:22 CEST
This incident affected: Welcome to the Jungle Solutions ATS.