Our Geolocation API
Incident Report for Welcome to the Jungle
Resolved
This incident has been resolved.
Posted Aug 08, 2023 - 15:11 CEST
Identified
We are currently experimenting some issues with our geolocation provider that prevent clients from using search fully on our main website. We have identified the root causes and we are currently working on a fix.
Posted Aug 08, 2023 - 14:24 CEST
This incident affected: Welcome to the Jungle main website.