Important changes in your account
Incident Report for Welcome to the Jungle
Resolved
Our maintenance is finished, everything should be back on track for Welcome Kit.
Posted Feb 14, 2022 - 12:39 CET
Monitoring
You will be automatically logged out from Welcome Kit.

Don't worry: you will be able to log back in straight away using the same credentials, but you will do it through a new admin space.

This update is part of the evolution of our products to provide you with a better, centralized experience and improved security.
Posted Feb 14, 2022 - 12:06 CET
This incident affected: Welcome to the Jungle Solutions ATS and Welcome to the Jungle Solutions ATS - Chrome Extension.